Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 15, 2025 - 02:12 AEST
Update
Latitude Checkout Services have come back online. Now monitoring.
Posted Apr 15, 2025 - 01:12 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary. Currently our 3rd party vendor has not provided an ETA on service restoration.
Posted Apr 14, 2025 - 23:30 AEST
Scheduled
Latitude would like to advise of a maintenance window between 20:00 14 APR 2025 and 03:00 15 APR 2025 AEST for our Latitude Interest Free Payment Services.
Outage: During this period, we expect up to 2 hours of downtime for Latitude/Gem Finance Payment Services. All online interest free payment transactions will be declined during the outage.
Description of Change: System maintenance
If you have any further inquiries, please contact the support team through the following: