Unplanned Payment Gateway Service Disruptions

Incident Report for Latitude Checkout Online

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 12:50 AEDT

Investigating

Latitude Merchant Services is investigating the issue on service disruptions with our 3rd party payment gateway provider.

Transactions and order management are impacted at this time.
Posted Mar 27, 2025 - 12:08 AEDT
This incident affected: Latitude Checkout Hosted Integration Service and Latitude Checkout Service.