Unplanned Payment Service Disruptions
Incident Report for Latitude Checkout Online
Resolved
Latitude Merchant Services would like to advise that the service disruptions have been resolved.

Current Status: Resolved

If you have any further inquiries, please contact the support team through the following:

Email: support.latitudecheckout@latitudefs.com
Posted Nov 16, 2022 - 09:37 AEDT
Update
Still working with Payment switch provider to resolve issues. Next update 10am AEDT.
Posted Nov 16, 2022 - 09:08 AEDT
Update
Still working with our payment gateway/switch provider to resolve the issue. More updates to follow shortly.
Posted Nov 16, 2022 - 08:26 AEDT
Investigating
Latitude Merchant Services is investigating the issue on service disruptions from our payment gateway/switch provider. More updates to follow shortly.
Posted Nov 16, 2022 - 07:47 AEDT
Identified
Latitude Merchant Services has identified the issue on the service disruptions and is working to have these resolved.

Impact: Payment transactions will be declined

If you have any further inquiries, please contact the support team through the following:

Email: support.latitudecheckout@latitudefs.com
Posted Nov 16, 2022 - 07:03 AEDT
This incident affected: Latitude Checkout Hosted Integration Service and Latitude Checkout Service.