Unplanned Payment Service Disruptions
Incident Report for Latitude Checkout Online
Resolved
This incident has been resolved.
Posted Jan 20, 2024 - 00:02 AEDT
Update
Latitude/Gem payment services have recovered. Issues resolved.
Posted Jan 20, 2024 - 00:01 AEDT
Update
Remediation activities ongoing.
Posted Jan 19, 2024 - 21:07 AEDT
Update
Remediation activities ongoing.
Posted Jan 19, 2024 - 19:10 AEDT
Update
Remediation activities ongoing.
Posted Jan 19, 2024 - 17:08 AEDT
Update
Root cause found. Support teams are working on remediation.
Posted Jan 19, 2024 - 15:55 AEDT
Investigating
Latitude/Gem Interest Free Payment Services are experiencing a technical issue. Support teams are investigating. Further updates will be provided every hour.
Posted Jan 19, 2024 - 14:22 AEDT
This incident affected: Latitude Checkout Hosted Integration Service and Latitude Checkout Service.